In association with heise online

13 July 2012, 14:26

jQuery 1.8 beta 2 improves support for older IE versions

  • Twitter
  • Facebook
  • submit to slashdot
  • StumbleUpon
  • submit to reddit

jQuery logo

The jQuery developers have released the second beta of jQuery 1.8 and are calling on users of the open source JavaScript library to help them test the new release. jQuery 1.8 beta 2 fixes several bugs, especially related to Internet Explorer 6, 7 and 8; jQuery plans to drop support for older IE versions in the future and maximising fidelity with those Internet Explorer versions in the current versions of jQuery is a priority.

The developers point out that this new version of the library needs an updated version of jQuery UI which has been released as jQuery UI 1.9.0pre; a maintenance release of jQuery UI 1.8 is planned but users are encouraged to update to jQuery UI 1.9 when it is eventually released.

While the developers are encouraging users to test the new version of jQuery, it should be kept in mind that this is a development version and should not be used on production systems. More details on the changes in jQuery 1.8 beta 2 can be found at the end of the release announcement. jQuery 1.8 beta 2 is MIT or GPLv2 licensed and can be downloaded from the project's web site; the source is available from its GitHub repository.

See also:


Print Version | Send by email | Permalink:

  • July's Community Calendar

The H Open

The H Security

The H Developer

The H Internet Toolkit