In association with heise online

31 August 2012, 14:44

jQuery 1.8.1 has compatibility workaround for custom pseudo-selectors

  • Twitter
  • Facebook
  • submit to slashdot
  • StumbleUpon
  • submit to reddit

jQuery logo In the recent 1.8.1 release of jQuery, the project's developers have addressed more than 30 issues found in version 1.8.0 of the JavaScript library from earlier this month. In jQuery 1.8, the old API for creating custom pseudo selectors was broken by the developers and a new API was introduced, but from jQuery 1.8.1 onwards, the API will be backwards compatible. The update includes a compatibility workaround which will allow older code to work with all versions of the Sizzle JavaScript CSS selector engine; further details about this can be found in the new official Sizzle documentation.

The developers also advise users not to use Quirks mode because "jQuery has never supported Quirks mode and we do not perform any testing in Quirks". Doing so can affect values such as $("window").height(). Furthermore, they recommend that users use the new version with jQuery UI 1.8.23 and jQuery Mobile 1.1.1 or later for the best compatibility. The announcement blog post contains a full list of fixes and changes in the update.

Version 1.8.1 of jQuery can be downloaded from the jQuery CDN (Code Delivery Network) as an uncompressed debug buildDirect download or as a compressed and minimised versionDirect download for production use; source code is available from the project's GitHub repository. jQuery is dual-licensed under the MIT Licence and the GPLv2.

See also:


Print Version | Send by email | Permalink:

  • July's Community Calendar

The H Open

The H Security

The H Developer

The H Internet Toolkit