Serious vulnerability in phpMyAdmin [Update]
All versions of phpMyAdmin, the popular MySQL administration tool, up to and including version 184.108.40.206 and the 3.0.0 release candidate 1, suffer from a code execution vulnerability. Versions 220.127.116.11 and 3.0.0-rc2 have been released with the vulnerability fixed. The phpMyAdmin developers describe the flaw as serious and recommend upgrading to the appropriate new version.
The advisory released by the phpMyAdmin developers stated the problem was that parameters of
sort_by were not escaped and an attacker, if they were already logged in, could manipulate this to call the PHP
exec function and run arbitrary code. The vulnerability was discovered by Norman Hippert in 3.0.0 RC1 initially, and checking showed that previous versions were also affected.
A partial workaround, for those unable to upgrade immediately, is to set
disable_functions = exec in
php.ini, but this change may have unwanted side effects, as it will block any PHP program from starting processes.
Update The vulnerability actually allows any PHP code to be run, so the above workaround is only effective against attacks where
exec would be called. It is therefore recommended that users upgrade as soon as possible.