In association with heise online

01 February 2011, 15:00

RubyGems 1.5.0 now supports Ruby 1.9.2

  • Twitter
  • Facebook
  • submit to slashdot
  • StumbleUpon
  • submit to reddit

RubyGems, the popular Ruby package manager which became the official package manager in Ruby 1.9, has been updated to version 1.5.0. The update comes a month after RubyGems 1.4.0 which didn't support the August 2010 release, Ruby 1.9.2. The new version now allows Ruby 1.9.2 users to upgrade to the latest RubyGems.

The update also sees the addition of post-build hooks which are able to cancel gem installations, a 40% faster Gem.find_files for Ruby 1.9, improved errors for corrupt Gem files and new upgrading documentation which covers Ruby 1.9. The gem update command also no longer tries, by default, to update RubyGems itself. There is, according to RubyInside, some incompatibility between RubyGems 1.5 and Bundler that is expected to be fixed "within the next 24 hours".

To update to RubyGems 1.5.0 on exisiting installations run gem update --system. Otherwise, RubyGems 1.5.0 can be downloaded from RubyGems is licenced under the Ruby licence.


Print Version | Send by email | Permalink:

  • July's Community Calendar

The H Open

The H Security

The H Developer

The H Internet Toolkit