In association with heise online

13 December 2011, 09:57

CyanogenMod drops Samsung Vibrant support after e911 issues

  • Twitter
  • Facebook
  • submit to slashdot
  • StumbleUpon
  • submit to reddit

Samsung's Vibrant The CyanogenMod developers have pulled support for Samsung's Vibrant smartphones from their free ROM, based on the Android Open Source Project (AOSP), after discovering that installing their ROM leaves the phone unable to call e911, the enhanced emergency service phone service. In a posting on Google+, developer Abhisek Devkota explained that the problem is unresolvable "without source code from Samsung related to the Radio interface layer and its interactions with the Audio layers", and Samsung vibrant users should use the stock Samsung ROMs for their own safety.

The developers have been attempting to patch the problem which initially manifested itself as an inability to call the e911 service. The patches managed to allow the e911 call to be placed but without audio, in which case an emergency dispatcher might assume the call is from someone unable to speak. Because e911, by design, sends GPS data with the call, the dispatcher would typically dispatch emergency responders to the location, though the developers note that "Vibrant GPS is also flaky... and neither will the 911 operators will be able to get a GPS lock to direct responders".

Devkota said the developers had been aware of the bug for a while, and "While some may see this as an issue that we can just acknowledge and move on from, the consequences of an actual emergency situation going wrong are not one we want to be a part of, whether the user is on CM or a derivative." Although they have announced the dropping of support and checked in the appropriate change, at the time of writing, the Vibrant is still listed on the CyanogenMod pages.


Print Version | Send by email | Permalink:

  • July's Community Calendar

The H Open

The H Security

The H Developer

The H Internet Toolkit